Problem1000--A+B问题 求两数之和

1000: A+B问题 求两数之和

Time Limit: 1 Sec  Memory Limit: 10 MB
Submit: 1423  Solved: 832
[Submit] [Status] [Web Board] [Creator:]

Description

输入两个整数,计算这两个整数的和

Input

两个整数 a 和 b ,介于 [0, 10] 之间 (0<=a,b<=10)

Output

输出计算结果

Sample Input

1 2

Sample Output

3

HINT

Q: Where are the input and the output? A: Your program shall always read input from stdin (Standard Input) and write output to stdout (Standard Output). For example, you can use 'scanf' in C or 'cin' in C++ to read from stdin, and use 'printf' in C or 'cout' in C++ to write to stdout. You shall not output any extra data to standard output other than that required by the problem, otherwise you will get a "Wrong Answer". User programs are not allowed to open and read from/write to files. You will get a "Runtime Error" or a "Wrong Answer" if you try to do so. Here is a sample solution for problem 1000 using C++/G++:

#include <iostream>
using namespace std;
int  main()
{
    int a,b;
    cin >> a >> b;
    cout << a+b << endl;
    return 0;
}

It's important that the return type of main() must be int when you use G++/GCC,or you may get compile error. Here is a sample solution for problem 1000 using C/GCC:

#include <stdio.h>

int main()
{
    int a,b;
    scanf("%d %d",&a, &b);
    printf("%d\n",a+b);
    return 0;
}

Here is a sample solution for problem 1000 using JAVA: Now java compiler is jdk 1.5, next is program for 1000

import java.io.*;
import java.util.*;
public class Main
{
            public static void main(String args[]) throws Exception
            {
                    Scanner cin=new Scanner(System.in);
                    int a=cin.nextInt();int b=cin.nextInt();
                    System.out.println(a+b);
            }
}

Source/Category

POJ